defaults write com.apple.finder AppleShowAllFiles -bool TRUE
Restart Finder.
killall Finder
defaults write com.apple.PowerChime ChimeOnAllHardware -bool true; open /System/Library/CoreServices/PowerChime.app
To tell it to check every day, just type:
defaults write com.apple.SoftwareUpdate ScheduleFrequency -int 1
All tweaks regarding screenshots require restarting ‘SystemUIServer’. To do so use killall SystemUIServer
.
defaults write com.apple.screencapture location ~/your/location/here
defaults write com.apple.screencapture name "New Screen Shot Name"
defaults write com.apple.screencapture type jpg
defaults write com.apple.screencapture disable-shadow -bool TRUE
say "Please do not try this one."
After -t
you enter the number of seconds you want to prevent your Mac from sleeping, dimming display or showing the screensaver.
caffeinate -t 150000
sudo mdutil -E /Volumes/DriveName
defaults write com.apple.finder QLEnableTextSelection -bool TRUE
killall Finder
defaults write com.apple.CrashReporter DialogType none
sudo defaults write /Library/Preferences/com.apple.mDNSResponder.plist NoMulticastAdvertisements -bool YES
When macOS connects to new networks, it checks for Internet connectivity and may launch a Captive Portal assistant utility application.
An attacker could trigger the utility and direct a Mac to a site with malware without user interaction, so it’s best to disable this feature and log in to captive portals using your regular Web browser by navigating to a non-secure HTTP page and accepting a redirect to the captive portal login interface (after disabling any custom proxy or DNS settings).
sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.captive.control.plist Active -bool false
defaults write com.apple.Safari TargetedClicksCreateTabs -bool TRUE
You can change the times to other settings to speed up or delay.
defaults write com.apple.dock autohide-delay -float 0.1; defaults write com.apple.dock autohide-time-modifier -int 0.3; killall Dock
Full height.
defaults write com.apple.dock persistent-apps -array-add '{tile-data={}; tile-type="spacer-tile";}' && killall Dock
Half-height.
defaults write com.apple.dock persistent-apps -array-add '{"tile-type"="small-spacer-tile";}' && killall Dock
defaults write com.apple.Dock showhidden -bool TRUE && killall Dock
Interval is in seconds, default is 60 minutes (3600).
sudo defaults write /System/Library/LaunchDaemons/com.apple.backupd-auto StartInterval -int 3600
sudo dscacheutil -flushcache && \
sudo killall -HUP mDNSResponder